Issue: Device not obtaining GPS lock
Symptoms:
- The EVO device will not obtain GPS lock, when left outside in an open environment, for > 15 minutes. This is indicated by the LED displaying a solid green light.
Expected Behaviour:
- When the EVO device is in Outdoor mode, and is left still in an open environment for 15 minutes, GPS lock should be obtained. This is indicated by the LED flashing once intermittently.
Causes:
- The Device is attempted to be used in a non-GPS Friendly environment (Urban Canyons, Stadiums, little sky or horizon visibility etc.)
- The Device is not in Outdoor mode
- Rare start-up issues where the device requires Power Cycling to obtain GPS lock
- Out-Dated GPS or Device Firmware
Troubleshooting Steps:
- Ensure the environment is suitable for obtaining GPS lock:
- Ensure device is not attempting to obtain GPS lock under cover or indoors
- Check how open is the Horizon/Sky, are you in an 'Urban Canyon' (Many nearby tall buildings), a Stadium or a Mountainous Area?
- Ensure device is not attempting to obtain GPS lock under cover or indoors
- Ensure the device is in the correct position with the antenna facing up (if lying down)/out from the Body (if worn).
See EVO Hardware Overview for more information - Check if the device is in Indoor or Outdoor Mode.
See How to Set the Devices and Console to Indoor or Outdoor Mode for more information - Check how long you have left the device to try and gain GPS lock; the device can take up to 15 minutes to establish a strong GPS lock
- Keeping the device still improves Device capability to gain GPS lock
- Power cycle (Turn off then back on again) the device if GPS lock hasn't been obtained
- Compare GPS lock to other EVO devices, in the same environment
- If GPS lock is still unobtainable, please Contact Support for further troubleshooting