Issue: Live Data update rates are worse than usual
Symptoms:
- Data update rate is significantly reduced relative to normal sessions
- Large dropouts or gaps between data being updated for all/most athletes
- Data Update rates live drop far quicker than normal as the Device moves further from the Receiver
- Particular Devices not detected whatsoever, or took a long time to be detected for the first time to begin the session
Expected Behaviour:
- In Ideal conditions, the Devices should update up to a maximum of 10 times a second, if in Clear Line of Sight of the Receiver, and within 250m of the Receiver
- The Devices should update at a reasonable rate (factoring in lines of sight, receiver position etc.), or similar to previous sessions in the same environment
Causes:
- Receiver disconnections/Receiver not being detected throughout the session
- 2.4GHz Radio Frequency (RF) Interference, being caused by 3rd party instruments/equipment, in a particular Venue or section of Venue
- Devices intermittently losing GPS lock
- Receiver not being setup/mounted correctly
- Physical obstructions between devices and receiver, blocking line of sight (Human Bodies, Metallic objects etc.)
- Devices not within Field-of-View of the Receiver
- Broadcaster.exe portion of GPSports Console not functioning for part of the session
- Single Device internal Hardware fault
Troubleshooting Steps:
- Check that the Receiver is detected by the PC and GPSports Console at all times. Periods of time where the Receiver has lost connection to the PC will cause gaps in Live Data from being received/recorded.
See GPS Receiver Not Detected by GPSports Console for more information. - If recording in Outdoor Mode, ensure the devices maintain GPS lock. If attempting to record live data in a GPS-challenging environment this could affect live update rates. The Devices will not transmit live when in outdoor mode, if GPS lock is not established.
- Check if the Live Data Update Rates is only poor for 1 device, or all
- Ensure the Receiver is mounted correctly and is facing the devices (not towards the ground or sky)
See GPS Receiver Overview for more information - Check your surrounding environment for potential sources of 2.4 GHz Radio Frequency (RF) interference. Examples include:
- Drones
- 3rd Party Antennas, Communication Towers etc.
- Some Wireless Cameras and Radios
- Wi-Fi Access Points
- Drones
- Ensure there are no Physical objects between the Devices and Receiver:
- The Human Body will block most if not all of the EVO signal. Check if Data Update Rates improve when the athlete has their back to the receiver (Device in clear line of sight to Receiver)
- Metallic Objects etc.
- The Human Body will block most if not all of the EVO signal. Check if Data Update Rates improve when the athlete has their back to the receiver (Device in clear line of sight to Receiver)
- Ensure the Devices are within range/field of view of the Receiver. Generally devices can be detected up to approximately 250m away. The Receiver also has a 160 Degree horizontal Field of View.
- Move your Receiver to a different location and observe if Data Update Rates improve. If so, this could indicate the initial location is an area of high 2.4GHz RF traffic.
If a particular group of Athletes or a specific Drill is needed to be recorded Live, position/locate the Receiver so that a majority of the Athlete's Backs are facing the Receiver so the Devices have a clear Line of Sight to the Receiver. - Restart GPSports Console, and resume the Live Activity
- Compare Data Update rates for Devices that are closer to the Receiver than those further away. If Data Update Rates significantly worsen more than usual when any device goes further away, this is indicative of RF interference.
Also Compare Devices where the Athlete has their back to the Receiver compared to Athletes facing the Receiver (Body blocking signal) - Compare Data Update rates for other Venues, or for a different day/session at the same Venue. This could indicate RF interference being present on a particular day/session or venue
- Perform a controlled Live Session in a different environment, such as an indoor session in your Office or Home, to ensure Receiver and Device(s) are functioning Live as expected
- Contact Support for further Troubleshooting